通达信涨停后缩量板主图指标公式

返回列表
通达信公式 922
公式说明

涨停:=IF((C-REF(C,1))*100/REF(C,1)>=9.90,1,0);

缩量涨停:=EVERY(涨停,2);

DRAWTEXT(缩量涨停,H*1.03,'缩量涨停'),COLORGREEN;

UU:=3;

A88:=SUM(C*V,UU);

B88:=SUM(V,UU);

市场价值线:MA(A88/B88,7)COLORYELLOW,LINETHICK3;

VAR41:=REF(CLOSE,1);

VAR42:=((SMA(MAX((CLOSE - VAR41),0),7,1) / SMA(ABS((CLOSE - VAR41)),7,1)) * 100);

VAR43:=((SMA(MAX((CLOSE - VAR41),0),13,1) / SMA(ABS((CLOSE - VAR41)),13,1)) * 100);

VAR44:=((BARSLAST((VAR43 < 23)) <= 3) AND CROSS(VAR42,VAR43));

VAR45:=((((CLOSE - MA(CLOSE,23)) / MA(CLOSE,20)) * 100) < -12.5);

VAR46:=LLV(LOW,5);

VAR47:=HHV(HIGH,10);

VAR48:=EMA((((CLOSE - VAR46) / (VAR47 - VAR46)) * 100),4);

VAR49:=EMA(((0.667 * REF(VAR48,1)) + (0.333 * VAR48)),2);

{VAR50:=1011131;

VAR51:=(IF((DATE <= VAR50),VAR45,0) OR IF((DATE <= VAR50),VAR1,0));}

DRAWTEXT((((0 - (-1 * VAR44)) AND VAR45) AND CROSS(VAR48,VAR49)) AND (VAR48 <=25),LOW*1.008,'急跌后超级大黑马'),COLORMAGENTA;

DRAWICON((((0 - (-1 * VAR44)) AND VAR45) AND CROSS(VAR48,VAR49)) AND (VAR48 <=25),L-0.10,26);

DRAWICON((((0 - (-1 * VAR44)) AND VAR45) AND CROSS(VAR48,VAR49)) AND (VAR48 <=25),L-0.38,26);

持股线1:MA(CLOSE,15),COLORMAGENTA,LINETHICK5;

MA10:MA(CLOSE,50),COLORBB0000;

DRAWKLINE(H,O,L,C);

{筹码峰}

时长:=120;

换手次数:=2;

选择方式:=1;

统计时长:IF(选择方式=1,CONST(SUMBARS(V/FINANCE(7)*100,换手次数)),时长),NODRAW;

KK:=统计时长;

高:=CONST(HHV(H,KK));

低:=CONST(LLV(L,KK));

XX:=(高-低);

均价:=AMOUNT/V/100,NODRAW;

L0:=低+XX*0/9;

L1:=低+XX*1/9;

L2:=低+XX*2/9;

L3:=低+XX*3/9;

L4:=低+XX*4/9;

L5:=低+XX*5/9;

L6:=低+XX*6/9;

L7:=低+XX*7/9;

L8:=低+XX*8/9;

L9:=低+XX*9/9;

MLZ:=SUM((CURRBARSCOUNT<KK+1)*V,KK),COLORWHITE;

ML1:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L0-0.001,L1+0.001))*V,KK)/MLZ;

STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML1*200)),(L0+L1*0.99)*0.49,(L0+L1*0.99)*0.5,18,0),COLORFF5555;

ML2:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L1,L2+0.001))*V,KK)/MLZ;

STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML2*200)),(L1+L2*0.99)*0.4999,(L1+L2*0.99)*0.5,18,0),COLORFFAA55;

ML3:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L2,L3+0.001))*V,KK)/MLZ;

STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML3*200)),(L2+L3*0.99)*0.4999,(L2+L3*0.99)*0.5,18,0),COLORAAFF55;

ML4:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L3,L4+0.001))*V,KK)/MLZ;

STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML4*200)),(L3+L4*0.99)*0.4999,(L3+L4*0.99)*0.5,18,0),COLOR5FFF00;

ML5:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L4,L5+0.001))*V,KK)/MLZ;

STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML5*200)),(L4+L5*0.99)*0.4999,(L4+L5*0.99)*0.5,18,0),COLORFFFFF0;

ML6:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L5,L6+0.001))*V,KK)/MLZ;

STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML6*200)),(L5+L6*0.99)*0.4999,(L5+L6*0.99)*0.5,18,0),COLORFF0FFF;

ML7:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L6,L7+0.001))*V,KK)/MLZ;

STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML7*200)),(L6+L7*0.99)*0.4999,(L6+L7*0.99)*0.5,18,0),COLOR509FDD;

ML8:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L7,L8+0.001))*V,KK)/MLZ;

STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML8*200)),(L7+L8*0.99)*0.4999,(L7+L8*0.99)*0.5,18,0),COLORAA5DDD;

ML9:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L8,L9+0.001))*V,KK)/MLZ;

STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML9*200)),(L8+L9*0.99)*0.4999,(L8+L9*0.99)*0.5,18,0),COLOR0055DD;

STICKLINE(C/REF(C,1)>=1.096 AND H=C,O,C,2,0),COLORYELLOW;

HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;

HJ_9:=FILTER(HJ_8,10);

HJ_10:=BARSLAST(HJ_9);

HJ_11:=REF(HIGH,HJ_10+2);

HJ_12:=REF(HIGH,HJ_10+1);

HJ_13:=REF(HIGH,HJ_10);

HJ_14:=MAX(HJ_11,HJ_12);

HJ_15:=MAX(HJ_14,HJ_13);

HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;

HJ_17:=HJ_10<150;

HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;

HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;

HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;

HJ_21:=VOL/MA(VOL,5)<3.5;

HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;

HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;

暴利:=FILTER(HJ_25,15);

MA54:=MA(CLOSE,54)NODRAW;

PL1:=(((CLOSE-MA54)/MA54)<0.1);

PL2:=(((CLOSE-MA10)/MA10)<0.3);

偏离率:=(((PL1=1) AND (PL2=1))*0.2);

平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);

妖股突破:=平台突破=-0.1;

XDF:=(暴利 OR 妖股突破);

VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);

VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);

FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);

妖股:=XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA;

DRAWICON(妖股,H*1.0395,7);

DRAWTEXT(XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,L*0.975,' 妖股'),COLORYELLOW;

DRAWTEXT(XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,L*0.995,' 妖股'),COLORRED;

DRAWTEXT_FIX(1,0.1,0.98,0,'艳红色线是持股线,黄线是反映市场价值线,接近收盘时股价上了黄色线就买进,股价在黄线之下的坚决不买,下黄线(收盘破红必跑) 毫不犹豫清仓,切记切记,做股票万万不要痴心妄想')COLORYELLOW;

LC11:=REF(CLOSE,1),NODRAW;

RSI11:=((SMA(MAX((CLOSE - LC11),0),3,1) / SMA(ABS((CLOSE - LC11)),3,1)) * 100);

FF:=EMA(CLOSE,3);

日:=150;昨前:=3;

高1:=REF(HHV(H,日),昨前);

低1:=REF(LLV(L,日),昨前);

H1:=高1-(高1-低1)*0.191;

H2:=高1-(高1-低1)*0.382;

H3:=高1-(高1-低1)*0.5;

H4:=高1-(高1-低1)*0.618;

H5:=高1-(高1-低1)*0.809;

顶:REFDATE(高1,DATE),COLORRED;

低点:REFDATE(低1,DATE),DOTLINE,COLORRED;

收盘破红必跑:MA(CLOSE,7)COLORRED,LINETHICK3;

CG:MA((LOW+HIGH+CLOSE*2)/4,10);

FL:HHV(CG,3);

FS:IF(CG<FL,(CG-(FL-CG)),FL);

FL1:HHV(CG,5);

FS1:IF(CG<FL1,(CG-(FL1-CG)),FL1);

FL2:HHV(CG,7);

FS2:IF(CG<FL2,(CG-(FL2-CG)),FL2);

FL3:HHV(CG,9),COLORFFABA3,LINETHICK2;

FS3:IF(CG<FL3,(CG-(FL3-CG)),FL3);

ZLZC1:=(HHV(H,144)-((HHV(H,144)-LLV(L,144))*0.618));

ZLZC2:=(HHV(H,144)-((HHV(H,144)-LLV(L,144))*0.5));

ZLZC3:=(HHV(H,144)-((HHV(H,144)-LLV(L,144))*0.382));

POLYLINE:(FS3>MA(FS3,5),FS3);

LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);

MTM1:=C-REF(C,1);DX:=100*EMA(EMA(MTM1,6),6)/EMA(EMA(ABS(MTM1),6),6);

买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

DRAWTEXT(FILTER(买=1,5),LOW-0.03,'拉升'),COLORGREEN;

DRAWTEXT(FILTER(买=1,5),LOW-0.22,'拉升'),COLORWHITE;

A63:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

A64:=SMA(A63,3,1);

A5:=SMA(A64,3,1);

A6:=3*A64-2*A5;

A76:=C-REF(C,1);

A68:=100*EMA(EMA(A76,6),6)/EMA(EMA(ABS(A76),6),6);

买88:=LLV(A68,2)=LLV(A68,7) AND COUNT(A68<0,2) AND CROSS(A68,MA(A68,2));

DRAWTEXT(FILTER(买88=1,5),H+0.05,'买进'),COLORYELLOW;

DRAWTEXT(FILTER(买88=1,5),LOW-0.25,'买进'),COLORYELLOW;

STICKLINE(买88,OPEN,CLOSE,2.5,0)COLORMAGENTA;

STICKLINE(买88,OPEN,CLOSE,1,0),COLORWHITE;



 

点击下载通达信公式调试用软件>>
赞赏本站

如果本站对您有所帮助,请打开您的微信,扫一扫下面的二维码,赞助本站,金额随意

算是您支持我们的发展,和对我们工作努力的肯定!小编在些表示感谢!


weix.jpg


联系客服:
客服 客服2
返回课程列表