通达信九转MACD指标公式

返回列表
热搜课程: 益盟高级课 量学 黑马王子 淘股吧教程 老马点金 月风先生教程 缠论 唐能通股票教程 伍朝辉 爱股轩股票教程 Python量化交易 狂龙十八段 财富讲坛股市108将 游资混江龙 缠中说禅 长投学堂
通达信公式 关注:5720
公式说明

DIF:EMA(C,12)-EMA(C,26);

DEA:EMA(DIF,9);

MACD:(DIF-DEA)*2,COLORSTICK;

STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.5,0),COLORLIRED;

STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,0.5,0),COLORLIGREEN;

A1:=C>REF(C,4);

NT:=BARSLASTCOUNT(A1);

TJ11:=NT=9;

TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);

AY:=(BACKSET(TJ11>0,9) OR   BACKSET(TJ13>0,NT))*NT;

DRAWTEXT(AY>0,MAX(DIF,MACD)*1.1,VAR2STR(AY,0)),COLORGREEN;

DRAWTEXT(NT=9,MAX(DIF,MACD)*1.1,'9'),COLORGREEN;

B1:=C<REF(C,4);

NT0:=BARSLASTCOUNT(B1);

TJ21:=NT0=9 ;

TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);

AY1:=(BACKSET(TJ21>0,9)  OR  BACKSET(TJ23>0,NT0))*NT0;

DRAWTEXT(AY1>0,MIN(DIF,MACD)*1.2,VAR2STR(AY1,0)),COLORLIMAGENTA;

DRAWTEXT(NT0=9,MIN(DIF,MACD)*1.2,'9'),COLORMAGENTA;




 

点击下载通达信公式调试用软件>>
赞赏本站
联系客服:
客服
返回课程列表