股票资源网

通达信立庄量主图指标公式

Class:公式教程 Time:2017-7-26 Hits:1670

N:=5;M:=13;

上:EMA(C,3),COLORRED,LINETHICK1;

中:EMA(C,5),COLOR00FF00,LINETHICK1;

下:EMA(中,5),COLORWHITE,LINETHICK1;

超买:MA(C,10)*IF(CAPITAL=0,1.04,1.1),POINTDOT,COLORGREEN,LINETHICK2;

超卖:MA(C,10)*IF(CAPITAL=0,0.95,0.9),POINTDOT,COLORRED,LINETHICK2;

获利盘%:WINNER(CLOSE)*100,NODRAW,COLORWHITE;

趋势线:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,LINETHICK4;

V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

V2:=(1-7/100)*(DMA(CLOSE,V1));

V3:=(1+7/100)*(DMA(CLOSE,V1));

V5:=MA((LOW+HIGH+CLOSE)/3,5);

支撑:=REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;

阻力:=REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;

MA1:=MEMA(CLOSE,5);

MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;

MA3:=IF(MA2>0,MA2,MA2);

MA5:=MA(CLOSE,N),COLOR888899;

MA13:=MA(CLOSE,M),COLORFF00F0,LINETHICK2;

VAR1:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))

OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND

REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND

C>=REF(C,1) AND C>=REF(C,2);

VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);

VAR3:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR

REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND

REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND

C<REF(C,1) AND C<REF(C,2);

VAR4:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND

REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);

VAR5:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND

REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND

REF(C,2)>=REF(C,4) AND C<REF(C,1);

VAR6:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);

VAR7:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;

VAR8:=VAR7 AND COUNT(VAR6,2);

VAR9:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);

VAR10:=EMA(MA(C,13),13);

VAR11:=FILTER((LLV(VAR9,2)=LLV(VAR9,7) AND COUNT(VAR9<0,2) AND

CROSS(VAR9,MA(VAR9,2)))=1,5);

VAR12:=FILTER((HHV(VAR9,2)=HHV(VAR9,7) AND COUNT(VAR9>50,2) AND

CROSS(MA(VAR9,2),VAR9))=1,1);

VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;

VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);

VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));

VAR16:=VAR8 AND NOT(REF(VAR8,1));

强攻:=IF(MA3>REF(MA3,1) AND MA3>=0,MA13,DRAWNULL),COLORYELLOW,LINETHICK2;

回调:=IF(MA3<REF(MA3,1) AND MA3>0,MA13,DRAWNULL),COLORGREEN,LINETHICK2;

{KDJ}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

金叉:=CROSS(J,D);

死叉:=CROSS(D,J);

买1:=(VAR14 OR VAR15) AND VAR11;

买2:=(VAR14 OR VAR15) AND VAR4;

买3:=(VAR14 OR VAR15) AND VAR2;

买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);

买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);

{涨停}

STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),

COLOR00FFFF;

{跌停}

STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),

COLORGREEN;

{蓝}

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.3,0),COLORFF7700;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.4,0),COLORFF9900;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.3,0),COLORFFBB00;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.8,0),COLORCYAN;

{红}

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.3,0),COLOR000099;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4,0),COLOR0000CC;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.3,0),COLOR0000FF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.8,0),COLORCC66FF;

{绿}    

STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR009900;

STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.4,0),COLOR00BB00;  

STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.3,0),COLOR00DD00;    

STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.8,0),COLOR00FF00;

{灰}

STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR999999;

STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;      

STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.3,0),COLORDDDDDD;    

STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.8,0),COLORFFFFFF;

STICKLINE(金叉,OPEN,CLOSE,1,0),COLORYELLOW;

STICKLINE(死叉,OPEN,CLOSE,1,0),COLOR000099;

DRAWICON(VAR16,LOW-0.02,7);

DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW-0.01,1);

DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9),HIGH+0.01,2);

X1:=(C+L+H)/3;

BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

EMA8:=EMA(C,8);

DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),

EMA8,'&ang;45升'),COLORWHITE;

VAR81:=1;

VAR82:=((((2*CLOSE)+HIGH)+LOW) / 4);

低金叉进:=20,COLORYELLOW,LINETHICK2;

高死叉出:=90,COLORGREEN,LINETHICK3;

VAR84:=LLV(LOW,5);

VAR85:=HHV(HIGH,4);

C1:=(EMA((((VAR82-VAR84)/(VAR85-VAR84))*100),4)*VAR81),COLORFF00FF,LINETHICK2;

C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR81),COLORFFFFFF,LINETHICK2;

条件:=CROSS(C1,C2) AND C1<40;

条件0:=CROSS(C2,C1) AND C1>90;

TJ1:=CROSS(C1,C2);

TJ2:=CROSS(C2,C1);

TJ3:=CROSS(C1,C2) AND REF(C1,1)<20;

TJ4:=CROSS(C2,C1) AND REF(C1,1)>80;

DRAWTEXT(条件0,H*1.02,'S'),COLORBLUE;

{DRAWTEXT(CROSS(C1,75),H*1.013,'险区'),COLORGREEN;}

DRAWTEXT(TJ3,L*0.98,'买底'),COLORFF00FF;

DRAWTEXT(TJ4,H*1.02,'逃顶'),COLORGREEN;

E1:=BARSCOUNT(C);

AH:=HHV(H,200);

AL:=LLV(L,200);

B0:=(AH-AL)/40;

KB1:=H+B0;

KB2:=L-B0;

STICKLINE((E1+0)/34=FLOOR((E1+0)/34),KB2,KB2-0.8*B0,1,0),COLORYELLOW,LINETHICK3;

DRAWTEXT((E1+0)/34=FLOOR((E1+0)/34),KB2-B0,'时窗'),COLORYELLOW;

水平面:=EMA(CLOSE,89),COLOR3399FF;

AAA:=(3*C+H+L+O)/6;

短趋:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;

中趋:=(LLV(短趋,2)+LLV(短趋,4)+LLV(短趋,6))/3;

{STICKLINE(C>中趋,短趋,中趋,0,0),COLORYELLOW;}

TTJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>短趋;

立桩量:=FILTER(TTJ1,5);

TTJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));

突破:=TTJ2=1;

TTJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));

三天法则:=TTJ3=1;

成立:=三天法则 AND 突破;

条件成立:=FILTER(成立,3);

DRAWICON(条件成立,L*0.91,1);

DRAWTEXT(条件成立,L*0.91,'立桩'),COLORFF26FF;

MA(C,9),LINETHICK0,COLORYELLOW;

MA(C,21),LINETHICK0,COLORRED;

IF(MA(C,9)<REF(MA(C,9),1),MA(C,9),DRAWNULL),LINETHICK0,COLORBLUE;

IF(MA(C,21)<REF(MA(C,21),1),MA(C,21),DRAWNULL),LINETHICK0,COLORGREEN;

VAR90:=((((HHV((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),4)<0) AND ((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2)>REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),1))) AND (REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),1)<REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),2))) AND (REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),2)<REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),3)));

DRAWTEXT(VAR90,L*0.98,'短买'),COLORRED;

DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C>=REF(C,1)

AND C>O,L*0.98,'追加'),COLORMAGENTA;

{股票教程网-股票公式网站 www.gwgz.net}

DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)>C AND

REF("MACD.DIF",BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1))+1)

<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA")

>0,L-0.02,'★M'),COLORFF00FF;{MACD底背离}

DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)>C AND

REF("KDJ.K",BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1))+1)<"KDJ.K" AND

CROSS("KDJ.K","KDJ.D"),L-0.10,'◎K'),COLORFF00FF;{KDJ底背离}

DRAWTEXT(REF(C,BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)>C AND

REF("RSI.RSI1",BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1))+1)

<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2")

>0,L-0.18,'◆R'),COLORFF00FF;{RSI底背离};

DRAWTEXT(REF(C,BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1))+1)<C

AND REF("MACD.DIF",BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1))+1)

>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF")

>0,H+0.16,'★M'),COLORGREEN;{MACD顶背离};

DRAWTEXT(REF(C,BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1))+1)<C

AND REF("KDJ.K",BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1))+1)

>"KDJ.K" AND CROSS("KDJ.D","KDJ.K")>0,H+0.08,'◎K'),COLORGREEN;{KDJ顶背离}

DRAWTEXT(REF(C,BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1))+1)<C AND

REF("RSI.RSI1",BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1))+1)>"RSI.RSI1"

AND CROSS("RSI.RSI2","RSI.RSI1")>0,H+0.04,'◆R'),COLORGREEN;{RSI顶背离};


{股票资源网,http://gpzyws.com,友情提供}
股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信选股公式,看盘主图副图指标,编写,修改,DLL加密等业务,详询客服!